Downloads

NOTE: You may not need to download WebCalendar. To get started even faster, you can choose use a Docker container instead.

WebCalendar 1.2 – Production

WebCalendar 1.2 is the latest production release of WebCalendar. You can download this release from SourceForge.net using the links below. The installation instructions can be found in the System Administrator’s Guide (found in the docs directory when you unzip/untar the WebCalendar distribution.).

Download WebCalendar-1.2.7.zip [1.5MB] 
Download WebCalendar 1.3 development version [1.9MB]

The User’s Manual is not included in the main download due to its size (another 600+ kb). You can also download the User Manual from SourceForge.net.

Download the User Manual

To view a list of all WebCalendar releases:

WebCalendar Releases

Git / Development Code

Note that all active development for WebCalendar is towards the newer 1.3 code base, which is found in the master branch. Legacy support for 1.2 releases will be found in the devel-1.2.8 branch. A snapshot of the latest WebCalendar 1.3 code in git can be obtained at:

master.zip

You can obtain the development code directly from git (“master” branch is the latest development code):

git clone https://github.com/craigk5n/webcalendar.git

24 thoughts on “Downloads

  1. Victor says:

    Hello,
    I am not able to install the webCalendar.

    Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /homepages/18/d681784932/htdocs/kalender/install/index.php:114 Stack trace: #0 {main} thrown in /homepages/18/d681784932/htdocs/kalender/install/index.php on line 114

    How to fix?

    Thank you!!!

    1. What version of WebCalendar are you trying to install? The current release does not use the set_magic_quotes_runtime call (which was removed from PHP in version 7.0).

  2. I installed ver 13 and didn’t work okay. So I deleted it. Now will try 12.x to see what happens.
    But, have a question: Is it possible to extend the calendar span, let’s say from year 1800 to year 1900 instead of the current year?

    1. Yes, you can enter events for dates in 1800. However, you may have some user interface limitations trying to do so. The easiest thing to do would be do hand-edit the URL to get to the year you want to go to (as in “month.php?year=1800&month=3”). From there, you can double-click on a date to add a new event for the year 1800. But it may be difficult for users to navigate to those events since most of the pulldown menus are 10 or so years in each direction.

  3. Client running v1.2.7 and needs to update.

    What is the simplest way to update without losing the database?
    Layout is easily fixed, but they have 5 years worth of events stored in database.

    Thanks!

  4. I am wondering if it is possible to eliminate some of the links at the top left (ie my calendar) in the public view. I just need the monthly display. I can put a button in the header for people to return to the main calendar if they click onto a date, and I don’t need the search or help links in my application

    1. In “System Settings”, you can change “Allow top menu” to be “No”. This will remove the menu at the top and replace that with links at the bottom of every page.

  5. Hi
    I installed the current version 1.3 of the web calendar on my webspace with PHP 7.4.
    Error messages appear during the installation.

    Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/www/webcal/includes/formvars.php on line 112
    Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/www/webcal/includes/formvars.php on line 81

    The installation wizard shows green everywhere. But no user with a password is created during the installation. If I call up the calendar and enter any password, error messages similar to those during the installation appear.

    Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/www/webcal/includes/formvars.php on line 81
    Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/www/webcal/includes/formvars.php on line 81
    Deprecated: Function get_magic_quotes_gpc() is deprecated in /home/www/webcal/login.php on line 90
    Warning: Cannot modify header information – headers already sent by (output started at /home/www/webcal/includes/formvars.php:81) in /home/www/webcal/login.php on line 140
    Warning: Cannot modify header information – headers already sent by (output started at /home/www/webcal/includes/formvars.php:81) in /home/www/webcal/login.php on line 146

    What can I do there?

    Kind regards
    Tim

  6. Im trying to install version 1.3.0 on php 7.4 and postgresql 13..

    When i get to step 3, I do the installation without any problem, but the it says “This appears to be an upgrade from version v1.1.0e-CVS to v1.3.0.”, but its a brand new install of the latest version. and when i hit the update button it gives lot of sql error of trying to upgrade tables and colums that already exist in the database, and i cant pass this step.

  7. I was using wecalendar 1.2.7 with php5 and postgreslq9. I’m now using php8 and postgreslq 13.7.

    webcalendar 1.2.7 errors with:
    Warning: Trying to access array offset on value of type null in /var/www/secure/html/lan/webcalendar/includes/config.php on line 53
    WebCalendar Error
    _getPhases: could not find ” in _filePhaseMap.

    I downloaded 1.3dev version and it errors with:
    Fatal error: Uncaught TypeError: fclose(): Argument #1 ($stream) must be of type resource, bool given in /var/www/secure/html/lan/webcalendar/install/index.php:636 Stack trace: #0 /var/www/secure/html/lan/webcalendar/install/index.php(636): fclose() #1 {main} thrown in /var/www/secure/html/lan/webcalendar/install/index.php on line 636

    1. I think you may be one of the few Postgres users. I am currently trying to update the latest code in git (master branch) to work with Postgres. Changes will be included in the v1.9.12 release.

  8. Hello,
    I’m french and when I try to add an event with a word containing the letter “é” : the sql crash !
    can you, please, help me ? I tried many solutions in working with UTF8.
    Sorry for my english 🙂

    1. Check the charset your MySQL database is using:

      SHOW VARIABLES LIKE 'character_set_server';

      If it is not utf8, then change it (replace your_database_name) with the WebCalendar database name:

      ALTER DATABASE your_database_name CHARACTER SET utf8 COLLATE utf8_general_ci;

  9. Good morning,
    I’m French and in my language, i can use the letter “é”.
    In the calendar, when I add or modify an event, if I put this letter in the title or in the description of the event, I have a sql error.
    I try plenty solutions with UTF8 with no result. Can you help me please ?
    thanks a lot, have a good day

  10. besides the user guide is there some where a person can get instructions on installing web calendar. I have been trying for over a month to get it to work. I downloaded several versions and tried them all. I guess the first question would be, do you have to build a database first and if so what are the privilege requirements.

    1. It’s supposed to be so simple with the Web-based UI that you don’t need instructions once you get to the install/upgrade page. Obviously, that hasn’t been your experience. If you are using MySQL, you don’t have to create the database or tables, the installer will do that for you if you have sufficient access through a db username and password. Alternately, you can setup the db by hand using the file in install/sql/tables-mysql.sql (which is what the installer uses).

Leave a Reply

Your email address will not be published. Required fields are marked *